[Rpcemu] merging RPCEmu and spoon edition

Matthew Phillips mgcc at sinenomine.freeserve.co.uk
Tue May 25 14:22:40 PDT 2010


In message <20100522095305.GA2762 at spod.org>
 on 22 May 2010 Peter Howkins  wrote:

> On Sat, May 22, 2010 at 07:59:10AM +0100, Matthew Phillips wrote:
> > Another feature of HostFS/EmuFS which surprised me, when running on
> > Ubuntu, was to do with NFS mounts.  I have my Iyonix's hard drive shared
> > using MoonFish amd mounted via NFS on the Linux machine.  When I made the
> > directory containing this mount point available to RPCEmu via EmuFS,
> > opening the directory which should have contained the Iyonix's hard drive
> > just resulted in a blank directory being shown.  I had hoped this would
> > be a handy way to share the RISC OS machine's drives without going to the
> > trouble of setting up ShareFS.
> 
> Hmm, given the flat fs model of linux, if a hostfs mountpoint worked in 
> one place it really should have worked in another (the NFS mountpoint).

That's what I thought.  I've just tried again this evening with EmuFS and
RPCEmu compiled from the riscos.info reporsitory from about March 2009.

I mounted the Iyonix's drive via NFS on the Ubuntu machine.

cd
ls iyonix/

This lists the files on the root of the Iyonix's hard drive.

Then I start RPCEmu and open a drive labelled Home, which is a read-only view
into my Linux home directory.  The folder "iyonix" appears there, but when I
open it EmuFS shows it as empty.

I will try to download the Spoon edition in due course and compare its
current behaviour.

-- 
Matthew Phillips
Dundee



More information about the Rpcemu mailing list