[Rpcemu] RPCEmu 0.8.7

Dave Symes dave at triffid.co.uk
Mon Sep 6 00:07:43 PDT 2010


In article <mpro.l8aegt002aj0f02o0 at wingsandbeaks.org.uk.invalid>,
   Jeremy Nicoll - ml roinfo <jn.ml.roi.39 at wingsandbeaks.org.uk> wrote:
> Dave Symes <dave at triffid.co.uk> wrote:

> > While I'm awaiting some comment from the Select mailing list, I've
> > done a very nasty hack that gets networking running on Select RO 4.39

> Nasty is right. Although you've explained the changes you've not
> explained what they achieve.

I thought I did make a note Jeremy.

The RPCEmu 4.39 boot gets to... 
"adfs::Hardisc4.$.!Boot.Choices.Hardware.Disabled.Boot.Predesk.SetUpNet"
and there's something wrong, because it hangs at at that point, and
there's no way without either deleting that file  (Consequence no
networking as SetUpNet is meant to load the Net configs) or doing the hack
I did, to get the boot to complete, and get networking.

The line. "Run BootResources:!Internet" contained in SetUpNet is not doing
it, because it can't find it, or some other reason, I obviously have no
idea, because I'm just a computer user.

I have no idea what the word "BootResources" is meant to be, there's no
file or directory on my computer called BootResources)

Doing a *Show BootResources in a Task window presents nothing.
Doing a *Show in a Task window then searching it for "BootResources" just
turns up a couple of references, but they are nothing to do with network
configuration.

Taken apart into to bits... What exactly is "Run BootResources:!Internet"
instructing the machine to do?

Why, if the line is in an Obey file, is it not doing it?

My hack forces the OS to take note of the networking configs in those
explicitly named files. two of which contain a "CheckError" reference
which, if not barred out will prevent the files from being actioned.

Again No idea what/why I'm just a computer user.

The fundamental problem is, there's something wrong with SetUpNet which
can't seem the find whatever its looking for and hangs the boot sequence.

With regard to what follows in your posting...

I'm sure you are right, unfortunately I'm just a computer user with a
veneer of knowledge, so most of what you've written is just words, and
while I may, from many years of hanging around here, understand individual
words, put together with other script/coding words... I have no idea.

Cheers
Dave

One last thought...
While Reporter is a wonderful app, I can't see how it could report on a
Boot Sequence that has only just started, the SetUpNet stall is so early
in the 4.39 boot sequence... Reporter isn't even a twinkle in the OSs eye
at that point.

D.

-- 

Dave Triffid



More information about the Rpcemu mailing list