[Rpcemu] Getting started with RPCEmu for Mac OS

Francis Devereux francis at devrx.org
Tue Sep 28 10:34:17 PDT 2010


On 28 Sep 2010, at 10:54, Chris Wraight wrote:

> Thanks Francis.
> 
>> Try http://www.devrx.org/software/rpcemu/rpcemu-spoon-fjd-2010-09-27.zip.
>> I've made the poduleroms loader skip files starting with '.', so it should
>> skip  the .DS_Store file.
> 
> This new version enables RPCEmu to get going. When I ran it, the Boot sequence 
> was still compressed, but I got to the desktop OK after a 'Disk not recognised' 
> error. Once there, I changed the filetype of HardDisc4 to 'Utility' and 
> double-clicked it. This unpacked the disc image, which I copied into the root 
> directory of the hard disc. I then configured RPCEmu to boot from HostFS as 
> instructed.
> 
> 
> After doing that, RPCEmu doesn't get to the desktop. The start-up screen reads:
> 
> RISC OS 24MB
> ARM 610 Processor
> RPCEmu Host filing system
> Error: Internal error: abort on data transfer at &00FBD00C (Error number 
> &80000002)
> 
> Followed by the *-prompt and flashing cursor. Typing *desktop brings up the 
> desktop, but the Boot sequence clearly hasn't run, and everything is very 
> unreliable - running any applications will crash the system, and the sprites are 
> corrupted.
> 
> Any pointers as to what I'm doing wrong would be much appreciated. I've attached 
> the error log below.

I've tried following the instructions at http://www.marutan.net/rpcemu/ro5.html to install RISC OS 5.17 and on my first attempt it didn't work either, although it failed for me in a different way:
After I've unpacked HardDisc4 and configured boot from hostfs with:
*configure filesystem hostfs
*configure boot
then after I reset with File->Reset RiscPC I get an error during boot: "File ,òflå,òflå,òflå,òflå,òflå,òflå,òflå' not found" - see the screenshot at http://www.devrx.org/software/rpcemu/screenshot_ro_5_17.png.  If I press cancel in the error box then the same error is repeated.

I then changed the CPU Type to SA110 (it was previously on the default of ARM610) and reset the emulated RiscPC again, and after that RISC OS 5.17 booted up to the desktop without problems.

Chris, I would recommend changing the CPU type to SA110.  If that doesn't work then you could try a different version of RISC OS, e.g. 4.39 or 4.02.

Perhaps we should we change the default CPU type to SA110?  I don't want to do this unilaterally for the Mac version though, I think that the default should be the same across all host platforms.

Thanks,

Francis




More information about the Rpcemu mailing list