[Rpcemu] Getting started with RPCEmu for Mac OS

Chris Wraight cdwraight at yahoo.co.uk
Tue Sep 28 13:28:46 PDT 2010


Thanks Francis.

> I've tried  following the instructions at 
>http://www.marutan.net/rpcemu/ro5.html
> to install RISC OS  5.17 and on my first attempt it didn't work either, 
>although
> it failed for me in  a different way. [snip details]
> I then  changed the CPU Type to SA110 (it was previously on the default of 
>ARM610)
> and  reset the emulated RiscPC again, and after that RISC OS 5.17 booted up to 
>the > desktop without problems.
> 
> Chris, I would recommend changing the CPU type  to SA110.  If that doesn't 
work
> then you could try a different version of  RISC OS, e.g. 4.39 or 4.02.


I tried changing to SA110, but this didn't work for me - I got exactly the same 
errors as before. None of the other CPU types worked either. Interestingly, the 
RAM size indicated by RPCEmu in the Preferences window is always 8MB less than 
that reported on the start-up screen (selecting 16MB gives 24MB, and so on).

I tried investigating the issue some more, but the instability of the system 
made it hard to discover what was going wrong. The ROM Apps (Edit, Draw, Alarm, 
etc.) seem to work fine once I've typed *desktop. None of the disc-based 
utilities work at all, most exiting with an abort on data transfer. Attempting 
to open !Boot.Resources hangs the machine.

There seems to be a particular problem with sprites. The !Boot folder doesn't 
use the correct sprite (it uses a generic 'App' sprite), and many of the other 
disc-based applications have a corrupted icon sprite.

I will try to get hold of a copy of RO4.02 in order to test that. If anyone has 
any ideas for further testing of RO5.17, I'd be happy to try them out.

Best wishes,
Chris



      




More information about the Rpcemu mailing list