[Rpcemu] RO5.17 (was Getting started with RPCEmu for Mac OS)

Musus Umbra musus at verelanthe.co.uk
Tue Sep 28 15:41:23 PDT 2010


I've just done a couple of quick experiments with RO5.17 with RPCEmu 
0.8.8, following the instructions at 
http://www.marutan.net/rpcemu/ro5.html

Here's what I did:
0) Made a clean install of rpcemu with an empty hostfs directory.
1) downloaded the ROM image (copied the "dUI300-00" file out of the zip 
file and into the rpcemu/roms directory).
2) Copied the self-extracting HardDisc4.util file into the hostfs dir.
3) Ran RPCemu (Cancel on the "Machine startup did not complete..." 
error)
4) *configure filesystem hostfs
5) *configure boot
6) Reset the RPC (with the Ctrl+End, File>Reset option)
7) Drop to a command line with F12
8) *settype HardDisc4/util Utility
9) *HardDisc4/util
A) Back to the desktop; move the contents of "HostFS::$.HardDisc4" into 
the root of HostFS (cancel any error about "no Boot application has been 
run on startup...")
B) Shutdown (Ctrl-Shift-F12)
C) Reset the RPC (Ctrl+End, File>Reset)
D) Say "Cool."

I tried different setups to see what worked and what failed;  here's my 
results...

RPCEmu built for x86_64, on Linux:

* cpu_type ARM610 + interpreter => hangs at the RO5 splash screen, with 
an hourglass running after step C.

* cpu_type ARM610 + recompiler => Gives an abort on data transfer at 
&FC141D5C at step 3, but Cancelling that error allows me to continue. 
Step D is instead replaced with the recurring 'ofla' error box after the 
RO5 splash screen.

* cpu_type SA110 + interpreter => All is well.

* cpu_type SA110 + recompiler => Same abort on data transfer as with 
ARM610, but no other problems.  RPCEmu boots into RO5.7 just fine and I 
say "Cool."


Built for i686 (still on Linux):

* cpu_type ARM610 + interpreter => Never makes it to step D.  On reboot 
the rpc sits at the RO5 splash screen with an hourglass running.

* cpu_type ARM610 + recompiler => Never makes it to step D.  On reboot 
the rpc throws a never ending series of 'File ofla not found error 
boxes'.

* cpu_type SA110 + interpreter => All is well.

* cpu_type SA110 + recompiler => All is well.


Conclusions:

Everything behaved pretty much exactly as I expected it to, i.e: 

* It's entirely possible to get RO5.17 up and running on rpcemu, and 
painlessly at that.

* cpu_type needs to be set to SA110 (and should be if you're wanting to 
use a recompiler build anyway, IIRC).

* a 64 bit build of RPCemu is fine in interpreter mode but even the 
'expect trouble' recompiler mode didn't give much grief.


Some of the failures I encountered look familiar from problems that 
others where having...  From my experience here, I'd say check that you 
have cpu_type set to SA110 and, for the sake of keeping things 
controlled, that you're working with a clean !Boot (e.g. start from a 
clean hostfs like I did and add anything else later).

Maybe that sheds some light, maybe not...

TTFN,
Adny

-- 
Erst wenn die Wolken schlafengehn	 | Personal: adny at verelanthe.co.uk
kann man uns am Himmel sehn		 | Techie: musus at verelanthe.co.uk
wir haben Angst und sind allein		 | WWW: verelanthe.co.uk/musus/
Gott weiss ich will kein Engel sein!	 | UT: adny.rsa at googlemail.com
-- Rammstein / Engel
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <http://www.riscos.info/pipermail/rpcemu/attachments/20100928/07f6e138/attachment.pgp>


More information about the Rpcemu mailing list