[Rpcemu] RPCemu v0.8.8 (compared to v0.8.3) on Mac OS

Stuart Spambin at argonet.co.uk
Thu Sep 30 01:45:56 PDT 2010


In article <mpro.l9jrer00001s20081.pittdj at pittdj.co.uk>,
   David Pitt <pittdj at pittdj.co.uk> wrote:

> > 
> > And the blank email said what?

> It was not blank here but it was rewndered as HTML, with MessengerPro
> 2.66.0 (Gemini as was) on Mac OS X.

Yes, Pluto showed the HTML as an attachment, dropped into Fresco it said:

-------------------------------------------------------------------------

Hi,

Having installed v0.8.8 for Mac OS last night (using FrancisD’s
rpcemu-spoon-0.8.8-fjd2-bin.zip), I 
encountered a number of problems booting into RISC OS that I hadn't
experienced with my build of v0.8.3 (that 
I’d built a year or so ago using instructions at
http://www.riscos.info/index.php/RPCEmu_Mac_Guide). I hope 
I've now worked past most of them but…

Q1) I think they all related to inconsistent RAM allocation and I wonder
if there still may be a problem here? I've 
now checked that the following all match up:
rpc.cfg mem_size = 128;
RPCemu Preferences menu selection = 128MB;
RISC OS !Boot - Discs - RAM disc enabled, 128.0 MB.
However, on start-up there is no RAM disc on the icon bar and looking in
Task display, RAM disc size shows 0K. Is 
that correct?
Although I can't now compare with v0.8.3 (please see Q4.ii below), I
believe something may have changed as a 
program that I regularly run as the first thing after start-up contains
the line "RMKill RAMFS" and this now fails with 
"Module RAMFS not found".

Q2) Command+F12 no longer seems to open the Command line under the icon
bar? The shortcut to open a Task 
window still works but is there an alternative now for this other route to
the command line?

Q3) Roughly every 2 out of 3 times I open RPCemu, the boot sequence stops
very early with an hourglass after 
the first 3 lines of text (that show the processor and "Acorn ADFS"). I
can't find a rpclog file saved anywhere to 
send you though? If I wait long enough, an error does appear as follows:
"Error: Unable to create files in 
"ADFS::IDEDisc4.$.!BOOT.Resources.!Scrap.ScrapDirs", error returned is
"Disc error 23 at 
:4/0000000007FE0000" (Error number &6)". I have since verified the hd4
'drive' is "ok", and I can't see any 
permission restrictions on the folder referred to. Moving the pointer out
of the window quickly enough as it boots 
MAY assist to bypass the error but that seems a bit random. Any ideas?

Q4) I found RPCemu spoon edition v0.8.3 very reliable after a year of
regular use (bar some problems with my 
own self-written but previously-stable (under-RISC-OS-3.11) BASIC
programs) but:
 (i) I am getting regular instruction fetch errors now under v0.8.8 with
no particular pattern as yet (e.g. upon 
opening a dir that next time opens fine) such as "Application may have
gone wrong. Click continue to try to resume 
or Quit to stop Application." Describe = "Internal error: abort on
instruction fetch at &00012AB0"; and
 (ii) now I can't seem to open v0.8.3 any more. Hopefully I won't need to
but is this to be expected? I was never 
able to open v0.8.3 from the rpcemu unix executable, but it was ALWAYS
successful running from Terminal. Now 
from Terminal it fails with a "Bus error" followed by "Rpcemu quit
unexpectedly". I have saved the Apple problem 
report details should it be worth forwarding? The RPCemu unix executable
does run to display the desktop but on 
clicking on IDEDisc4 or the RAM disc, it gives the error “Disc not
understood - has it been formatted?”. I 
think this was the problem a year ago and why I always used Terminal
thereafter.

 

Q5) A command "Set Alarm$Options …." for configuring the !Alarm
application which worked fine under 
RPCemu v0.8.3 seems to have stopped working?


Can you help / advise with these please?
 

Specification and other info should it be helpful:

-    I’m running Mac OS 10.6.4 on an Intel iMac 9.1.

-    RISC OS 4.02 ROM’s.

-    To set up v0.8.8 I created a new folder with the unzipped 0.8.8-fjd2,
along with copies of hd4.hdf, roms folder, 
hostfs folder, rpc.cfg and cmos.ram, and set this folder to be the data
directory.

-    With both v0.8.3 and v0.8.8 I get a duplicate HostFS on the icon bar,
but both open fine and point to the same 
folder.

-    I found a very strange issue when testing v0.8.8 last night whereby a
RISC OS text file which one of my BASIC 
programs spools (one line of text) to, contained over 800Mb of random
data, but amongst which were references 
to a load of filenames I have on Mac OS. Hopefully this is a one-off but
I’m intrigued how this could have 
happened?

-    Contents of rpc.cfg file:-
network_type = off
mouse_following = 1
cdrom_type = 0
cdrom_enabled = 1
blit_optimisation = 0
refresh_rate = 60
stretch_mode = 0
sound_enabled = 1
vram_size = 2
cpu_type = ARM610
mem_size = 128
ipaddress = 172.31.0.1
 

The build of version 0.8.8 is considerably faster than v0.8.3
incidentally! Thank you for everyone's ongoing work 
and time on this project.

Thanks & Regards,
Al Webb


 

----------------------------------------------------------------------
AUSI.COM at http://ausi.com - the BEST FREE EMAIL

HOLIDAYS & FUN -- AUSITRAVEL at http://ausitravel.com

-- 
Stuart Winsor




More information about the Rpcemu mailing list