[Rpcemu] Networking on Mac OS X Lion

David Pitt pittdj at pittdj.co.uk
Mon Nov 7 22:38:56 PST 2011

In message <673A7B81-1A33-44F6-BDF3-1DEC75D8CC05 at devrx.org>
  Francis Devereux <francis at devrx.org> wrote:

> On 6 Nov 2011, at 11:58, David Pitt wrote:

>> TunTap has now been updated to run on Lion.
>> http://tuntaposx.sourceforge.net/
>> The results are mixed.
>> Using the latest rpcemu 0.8.8-devel, rpcemu-spoon-fjd-2011-10-25b.zip,
>> networking appears to be OK on OS4.04 and OS4.37. However with OS5.17
>> NetSurf will fetch from the first URL requested but nothing
>> thereafter.

> Is this OS5.17 behaviour Lion-specific or does it happen on older
> versions of OS X too? I can reproduce it on my OS X 10.7.2 machine but
> I haven't tried earlier versions of OS X.

I don't have any earlier versions of OS X to try now. All I can say is 
that the version of 0.8.8 that worked on Snow Leopard does not now
work on Lion, and the problem does seem to be confined to OS5.17.

> I've implemented a hacky fix for it: previously if the network buffer
> was full then the network read thread would wait forever for the
> EtherRPCEm module in the emulated machine to read the network data.
> Now the network read thread only waits for a second, and before each
> second it waits it re-raises the EtherRPCEm podule interrupt. This
> seems to work but I'm not sure why - enlightenment and/or suggestions
> for a better fix welcome!

I don't know anything useful I'm afraid.

As OS4.04 and OS4.37 do not show the problem my first thought would be 
to query the ROOL rom.

David Pitt

MessengerPro 6 on an ARMini running RISC OS 5

More information about the Rpcemu mailing list