[Rpcemu] SOLVED : Rebuilding RPCemu - problem with Allegro

Terry Duell tduell at iinet.net.au
Fri Nov 11 20:02:55 PST 2011


On Fri, 11 Nov 2011 09:42:52 +1100, Terry Duell <tduell at iinet.net.au>  
wrote:

> Hullo All,
> I have just upgraded from Fedora 15 to Fedora 16 x86_64 and my RPCemu  
> fails. It can't find liballeg.so.4.2.
> The library that is now installed is liballeg.so.4.4.2.

I have solved the problem(s).
Firstly, the upgrade to Fedora 16 somehow left me without the allegro-dev  
package.
Next there was an issue with AM_PATH_ALLEGRO which should be sorted via  
aclocal, I think, but that eventually came good...but I'm not sure why!
Finally, I had to point the linker to libm and libpthread, which I did in  
the makefile. I suspect there are better ways of doing that. I think these  
libs are explicitly needed to be defined due to changes in Fedora...a  
guess.
Anyway, it is now all sorted.
Finally a postscript, I don't think I specified which version of RPCemu I  
was building. It was v.168. I have tried later versions as they have come  
along, but have always reverted to 168, mainly because it has been quite  
stable and I haven't been happy with the reversion from emufs to hostfs in  
the later versions.

Cheers,
-- 
Regards,
Terry Duell



More information about the Rpcemu mailing list