[Rpcemu] RISC OS 6.20 Install Guide

Dave Symes dave at triffid.co.uk
Sat Feb 2 04:41:41 PST 2013


In article <807b621753.old_coaster at old_coaster.yahoo.co.uk>,
   Tony Moore <old_coaster at yahoo.co.uk> wrote:
> On 1 Feb 2013, Dave Symes <dave at triffid.co.uk> wrote:

> > Something else I meant to ask...
> >
> > I've had Select 6.20 installed on this real SARPC since it first
> > arrived on the scene. (6.20 that is). One of the first things I needed
> > to do was get rid of that Nausea inducing menu slide in from the right
> > hand side of the screen. But, that was a long time ago, and now I've
> > installed RO 6.20 on a RPCemu install, I need to switch that slide out
> > off, but cannot remember just how I did it the last time.
> >
> > Can anyone enlighten me please, as MAV is in danger of putting me on
> > the floor or throwing up on my keyboard?

> Configure... > Windows > Windows > Menu slide > Off

> Tony

Ah yes, thanks Tony.

My problem I've discovered is this:
On this real SARPC I have that menu, but on the RPCemu 6.20 install the
windows configuration dialogue is quite different.

Where the "Menu slide part is on the real SARPC dialogue, on the Emu
config window I have instead...

 "Backgrounds"
"Textured window backgrounds"
"Textured menus"
"Alternative menu texture."


The switcher icon-Info shows the same Version, Date and Kernel numbers for
both the real RPC and the Emu 6.20.

I've now run VRPC-Adjust SA which I also have running 6.20 and the
Configure... > Windows > Windows > Menu slide option is there.

I've not checked all my Emu 6.20 installs (I started from different RO 
versions 4.02, 4.39) but not one Emu/6.20 install has the correct Windows
Config menu.

It appears something is not quite right with the RPCemu 6.20 install, and
for whatever reason, the 6.20 Window config tool is showing the 4.39
Window config.

So from this real SARPC, I've manually taken the
"...HD4.$.!Boot.RO600Hook.Res.Configure" directory and put it in the
RPCemu 6.20 600Hook directory.
Rebooted Emu and I now have the correct Window Config tool and tghe Menu
slide is Off.

Bit busy ATM, but later I must check and see if all the other Config tools
have the correct 6.20 entries, or are still running the 4.39s.

In the meanwhile... Any thoughts?

Dave

-- 

Dave Triffid



More information about the Rpcemu mailing list