[Rpcemu] Issues with 0.8.9 on Mac (Mountain Lion)

Luke Evans luke at eversosoft.com
Fri Jan 4 22:35:33 PST 2013


Actually, further to (1) it appears that if the RPCEmu window is positioned near the origin of the main screen (bottom left) then the mouse behaves correctly when re-entering the window (transitioning from the Mac OS X desktop to the RISCOS desktop in RPCEmu).  So, I think that does support the hypothesis that the issue is some offset calculation.

I don't know if this is significant, but the two monitors that I have attached to my Mac Pro have slightly different geometries (the main monitor being higher resolution).  Mac OS X allows you to position the logical geometry of the two screens adjacent to each other (to the left or right) with an arbitrary vertical offset of a smaller screen against a larger one.  I'll need further play-time to determine if this, or simply the dual screen setup, is a factor.


On 2013-01-04, at 7:28 PM, Luke Evans <luke at eversosoft.com> wrote:

> I've just installed RPCEmu on Mountain Lion - originally off the ROOL USB drive (0.8.8), then the 0.8.9 build from the web.
> There seem to be a few issues however:
> 1. The mouse seems to get messed up after leaving the RPCEmu window for the first time.  When returning to the window, the position of the RISCOS mouse will get clamped to a particular boundary and not move beyond that - perhaps affording some movement in a portion of the RISCOS desktop, but not all.
> This seems to be an incorrect bounds/offset calculation when the mouse reenters the window.  I wonder if this has to do with multiple monitors (which I have), but I haven't tried on a single monitor system yet.  This bad state seems to get reset if the RPCEmu window is deactivated and reactivated (i.e. click on another window, then click back on the RPCEmu window's title bar), but the situation will arise again once the mouse leaves the window bounds again.




More information about the Rpcemu mailing list