[Rpcemu] Risc OS 6.20

Tony Moore old_coaster at yahoo.co.uk
Mon Jan 7 04:12:57 PST 2013


On 6 Jan 2013, Gerald Holdsworth <gerald at hollypops.co.uk> wrote:

[snip]

> I started with a 4.39 install (!Boot sequence as well), and ran the
> RISC OS 6 install within NewUsers directory on the CD. When it got to
> the bit about installing the soft loadable ROMS, I cancelled the
> install (as I knew if I continued, it would hang). I then followed the
> instructions provided on the page to decompress the Select6i1 file
> (found in NewUsers.Data) and then put them into the roms folder in the
> RPCemu data folder (in place of the 4.39 ones).

Ingenious! However, I've just tried that, and find that it leads to the
same error, as reported previously.

I don't doubt what you say, but I'm having difficulty in understanding
why it should work, since the 6.20 boot sequence soft-loads the 6.20 rom
image, from !Boot.Softload which, in this case, contains no rom-image.

> Not sure what the Select6i1na file is though - haven't tried that one.

I vaguely remember that it may have something to do with a pre-release
version of the original RO6. I may be wrong. Anyway, a ReadMe file
issued with the RO6.14 upgrade says that

   Note that this version of !Boot contains both the standard and 'na'
   versions of the Select5i1 ROM but if you are using the 'na' version
   of Select 4i2 or 4i4 you will need to use Configure to use the 'na'
   version of Select 5i1.

so it seems that the 'na' version is not relevant to this discussion.

> Initially, I did just replace the 4.39 ROMs for the 6.20 one, with the
> 4.39 !Boot sequence, before I went to the trouble of installing the
> new sequence.
>
> It could be that I am using a Mac to decompress the file, or the Mac
> version of RPCemu can handle it better. I've still to try the same
> trick on my Windows PC to see if it works there.

Please try! I'm sure that many readers would be interested to know the
result.

> Incidentally, I've got it set up as a 64MB 2MB VRAM SA110
> RPC...whether that makes a difference or not.

Tried those settings - same error message.

Tony






More information about the Rpcemu mailing list