[Rpcemu] Risc OS 6.20

Gerald Holdsworth gerald at hollypops.co.uk
Mon Jan 7 09:37:28 PST 2013


-----Original Message----- 
From: Tony Moore
Sent: Monday, January 07, 2013 12:12 PM
To: Rpcemu at riscos.info
Subject: Re: [Rpcemu] Risc OS 6.20

On 6 Jan 2013, Gerald Holdsworth <gerald at hollypops.co.uk> wrote:

[snip]

> I started with a 4.39 install (!Boot sequence as well), and ran the
> RISC OS 6 install within NewUsers directory on the CD. When it got to
> the bit about installing the soft loadable ROMS, I cancelled the
> install (as I knew if I continued, it would hang). I then followed the
> instructions provided on the page to decompress the Select6i1 file
> (found in NewUsers.Data) and then put them into the roms folder in the
> RPCemu data folder (in place of the 4.39 ones).

Ingenious! However, I've just tried that, and find that it leads to the
same error, as reported previously.

I don't doubt what you say, but I'm having difficulty in understanding
why it should work, since the 6.20 boot sequence soft-loads the 6.20 rom
image, from !Boot.Softload which, in this case, contains no rom-image.

[snip]

> Initially, I did just replace the 4.39 ROMs for the 6.20 one, with the
> 4.39 !Boot sequence, before I went to the trouble of installing the
> new sequence.
>
> It could be that I am using a Mac to decompress the file, or the Mac
> version of RPCemu can handle it better. I've still to try the same
> trick on my Windows PC to see if it works there.

Please try! I'm sure that many readers would be interested to know the
result.

> Incidentally, I've got it set up as a 64MB 2MB VRAM SA110
> RPC...whether that makes a difference or not.

Tried those settings - same error message.

Tony

Hi Tony,

On my PeeCee now - I found I had an older version of RPCemu installed, so I 
updated to the latest then took the ROM images from my Mac (and the HostFS 
folder) and plugged them into the PC version. The only problems I 
encountered was the FontManager and Desktop were unplugged, for some bizarre 
reason (not sure it was to do with RISC OS 6.20).

Anyway, have got both the Interpreter and Recompiler (not sure what the 
difference is here) running version 6.20, and it appears stable.

Incidentally, my PC is a AMD Athlon 64 with 3GB RAM and ATI Radeon HD3200 
graphics running Windows 7 Home Premium - if that makes any difference. The 
Risc PC model emulated is the same as before.

Cheers,

Gerald.




More information about the Rpcemu mailing list