[Rpcemu] Risc OS 6.20

Tony Moore old_coaster at yahoo.co.uk
Tue Jan 8 02:29:45 PST 2013


On 7 Jan 2013, "Gerald Holdsworth" <gerald at hollypops.co.uk> wrote:

[snip]

> On my PeeCee now - I found I had an older version of RPCemu installed,
> so I updated to the latest then took the ROM images from my Mac (and
> the HostFS folder) and plugged them into the PC version. The only
> problems I encountered was the FontManager and Desktop were unplugged,
> for some bizarre reason (not sure it was to do with RISC OS 6.20).
>
> Anyway, have got both the Interpreter and Recompiler (not sure what
> the difference is here) running version 6.20, and it appears stable.
>
> Incidentally, my PC is a AMD Athlon 64 with 3GB RAM and ATI Radeon
> HD3200 graphics running Windows 7 Home Premium - if that makes any
> difference. The Risc PC model emulated is the same as before.

I've tried again with a fresh install of RPCEmu 0.8.9, running on Win7
HP 32bit. Starting with 4.39 rom-image, and boot sequence, I ran the
6.20 Install application, aborting prior to installation of the rom. I
then copied the 6.20 rom-image to RPCEmu\roms, on the Windows side, and
to !Boot.Softload, on the RISC OS side. All this is, I believe, as you
described it earlier. However, on re-booting, the sequence stops, as
before, with the same Error: DataAbort: Abort on data transfer at
&0380BE64 (Error number &80000002). Maybe I've misunderstood something.

Has anyone else succeeded in running 6.20?

Tony






More information about the Rpcemu mailing list