[Rpcemu] Risc OS 6.20

Gerald Holdsworth gerald at hollypops.co.uk
Tue Jan 8 05:13:45 PST 2013


On 8 Jan 2013, at 10:29, Tony Moore wrote:

> On 7 Jan 2013, "Gerald Holdsworth" <gerald at hollypops.co.uk> wrote:
> 
> [snip]
> 

[snip]

> 
> I've tried again with a fresh install of RPCEmu 0.8.9, running on Win7
> HP 32bit. Starting with 4.39 rom-image, and boot sequence, I ran the
> 6.20 Install application, aborting prior to installation of the rom. I
> then copied the 6.20 rom-image to RPCEmu\roms, on the Windows side, and
> to !Boot.Softload, on the RISC OS side. All this is, I believe, as you
> described it earlier. However, on re-booting, the sequence stops, as
> before, with the same Error: DataAbort: Abort on data transfer at
> &0380BE64 (Error number &80000002). Maybe I've misunderstood something.
> 
> Has anyone else succeeded in running 6.20?
> 
> Tony

Hi Tony,

I didn't put the rom image into the Softload directory in !Boot - however, as these getting softloaded depends on the !Softload Obey file in there (mine says /Boot:Utils.Softload .NONE.), I don't think that'll make a difference.
Also, I'm using 64 bit Windows...again, I can't see why that would make a difference.

When you fire up RPCemu with 6.20, do you get the initial screen telling you the OS version?
If you were to boot it without any !Boot, does it go to the green screen asking where you would like to boot from?
Could it be something in the cmos.ram file? On the PC, I did have those two modules unplugged initially which prevented booting onto the Desktop.
Silly question, but the obvious can easily be overlooked - you did take out the 4.39 roms from the Windows rom folder?
Would it help if I sent you a copy of my rom image?

Cheers,

Gerald.


More information about the Rpcemu mailing list