[Rpcemu] See a CD in RPCEmu

Dave Symes dave at triffid.co.uk
Tue Mar 12 00:08:17 PDT 2013


In article <1f0ef52a53.old_coaster at old_coaster.yahoo.co.uk>,
   Tony Moore <old_coaster at yahoo.co.uk> wrote:
> On 11 Mar 2013, Dave Symes <dave at triffid.co.uk> wrote:

[Snippy]

> > That's interesting Tony, the CD I was using (and failing) was a RO
> > 6.20 install CD.
> >
> > Out of interest... were you attempting this through the RPCEmu
> > Menubar Disc

> 'Load disc:0' (which I had not tried before) opens a Windows Explorer
> window and, in this, clicking on DVD RW Drive (E:) leads to the Windows
> error 'Insert a disc', as you said. The data, or music CD, is ejected,
> and the DVD RW Drive (E:) entry disappears from the Explorer window.

Yes, I thought it was weird that the Drive E: entry was disappearing from
the Explorer window when I tried.

> > or from the Icon bar CD drive icon?

> Having set RPCEmu Config > Discs > CD-ROMs > CD Drives > 1, a CD drive
> icon appears on the iconbar. Clicking on that icon opens the root
> directory, etc, of a data CD, as I said - it still does - and files can
> be read, as normal. However, a music CD causes RPCEmu to vanish.

> Tony

Yes, that's what I did, but the end result is different.
Having looked a bit closer, the Icon bar Info of the drive icon says,
"CDFS:0" and  "No CD ROM drive present" Ooer!
It obviously is and had a RO Select 6.20 install CD in the drive, so
something is missing behind the scenes.

Clicking (Mouse) Select on the icon bar icon presents...
"Message from CDFS filer"
"Soft-load driver not present."

Eh!
Hangonamo while I run Verma.

I have Active...
CDFS            2.70  15th Feb 2007
CDFSFiler       4.22  08th Feb 2009
CDFS Resources  2.37  08th Feb 2009
CDFSDriver      2.38  26th Feb 2007

Plus a few old CDFSSoftnnnn  where nnn is the name of a drive manufacturer.

I wonder what might be missing?

Dave

FWIW. The VRPC-AdjustSA install on another machine doesn't work via a
Drive on the Icon bar either (Same result amd messages) on that I access
the underlying CD/DVD drive via a VRPC HostFS definition that puts a drive
on the icon bar.

Unfortunately, files taken off the ADFS CD (6.20 Installer) have all lost
their filetypes... And as expected, only those in archives retain the
filetypes.
D.

-- 

Dave Triffid



More information about the Rpcemu mailing list