[Rpcemu] Allegro not installed Mint 17

Sean Kelly sean at caluse.net
Wed Oct 1 02:33:06 PDT 2014


Phew, thanks everybody I have now sorted it, I found the solution at:

https://wiki.allegro.cc/index.php?title=Using_Allegro_with_autoconf/KDevelop

"This comes about because aclocal cannot find allegro.m4. aclocal does 
not seem to search in /usr/local/share/aclocal for m4 files. This means 
that if you built allegro from sources yourself, you probably will have 
to move the file `/usr/local/share/aclocal/allegro.m4` to 
`/usr/share/aclocal/`."

I did not build Allegro from sources myself, but I copied (too timid to 
move - I might break something else) Allegro.m4 to the second location. 
It still did not compile straight away, I got the DSO error that struck 
with Mint 16. However, repeating the process as previously suggested by 
Kai and slightly modified by me worked a treat, which is to say:

make clean
LIBS="-lm -lpthread" ./configure --enable-dynarec
make

Back to RiscOS happiness.

Sean.


On 01/10/14 07:12, Kai Thomsen wrote:
> On Tue, 30 Sep 2014 10:20:06 +0100
> Sean Kelly <sean at caluse.net> wrote:
>
>> I have just moved from Mint 16 to Mint 17 and am trying to recompile
>> RPCEmu but it looks as if Allegro 4 is not installed, see the
>> following error:
>>
>> ./configure: line 4634: syntax error near unexpected token `,'
>> ./configure: line 4634: `   AM_PATH_ALLEGRO(, , as_fn_error $?
>> "building RPCemu requires Allegro to be installed" "$LINENO" 5)'
> Have you tried running this command?
>
>    autoreconf --verbose --force
>
> Maybe it is just that the autotools-related files are outdated.
>
>
> --Kai
>
> _______________________________________________
> Rpcemu mailing list
> Rpcemu at riscos.info
> http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu

-- 
Sean Kelly
+44(0)7768 481944




More information about the Rpcemu mailing list