[Rpcemu] Allegro not installed Mint 17

Jim Lesurf jcgl at audiomisc.co.uk
Wed Oct 1 04:06:40 PDT 2014

I'd be grateful if someone can clarify and correct/confirm my understanding
of this for two related reasons...

A) In the past when I've upgraded from one Xubuntu distro to another my
previously made RPCemu 'just worked' with no need to recompile. Although I
think I had to install allegro4, but I'm afraid I can't remember. I realise
that in general you should remake, but doing the above was a lot simpler
and worked fine. :-) So one question I have in mind is if this might again
be possible.

I tried this morning to run a copied across made RPCemu on a machine with
Xfce Mint and it didn't work. Even issuing an 'exec' command to start it in
a terminal caused the terminal to evaporate. I've not yet tried installing
allegro4 and seeing if that fixes the problem because I'm not sure which
specific packages I need. Is it just the allegro4-dev package?

If so, do I then need to copy the '.m4' files as below? (I assume so, but
want to check in the above context).

B) Hoping the above might work to save effort. :-) But if it doesn't I'll
start from scratch and try to make a new working version, copying across my
existing hd4, hostfs, etc, once made. So my questions here are how I
combine what Sean explained with the previous make process. Afraid I've
forgotten the details so will look for the webpage or find that in my
notes. But a clearer step by step of the whole process would help me, and I
guess others in due time.



In article <542BCA52.7060807 at caluse.net>, Sean Kelly <sean at caluse.net>
> Phew, thanks everybody I have now sorted it, I found the solution at:

> https://wiki.allegro.cc/index.php?title=Using_Allegro_with_autoconf/KDevelop

> "This comes about because aclocal cannot find allegro.m4. aclocal does
> not seem to search in /usr/local/share/aclocal for m4 files. This means
> that if you built allegro from sources yourself, you probably will have
> to move the file `/usr/local/share/aclocal/allegro.m4` to
> `/usr/share/aclocal/`."

> I did not build Allegro from sources myself, but I copied (too timid to
> move - I might break something else) Allegro.m4 to the second location.
> It still did not compile straight away, I got the DSO error that struck
> with Mint 16. However, repeating the process as previously suggested by
> Kai and slightly modified by me worked a treat, which is to say:

> make clean LIBS="-lm -lpthread" ./configure --enable-dynarec make

> Back to RiscOS happiness.

> Sean.

> On 01/10/14 07:12, Kai Thomsen wrote:
> > On Tue, 30 Sep 2014 10:20:06 +0100 Sean Kelly <sean at caluse.net> wrote:
> >
> >> I have just moved from Mint 16 to Mint 17 and am trying to recompile
> >> RPCEmu but it looks as if Allegro 4 is not installed, see the
> >> following error:
> >>
> >> ./configure: line 4634: syntax error near unexpected token `,'
> >> ./configure: line 4634: `   AM_PATH_ALLEGRO(, , as_fn_error $?
> >> "building RPCemu requires Allegro to be installed" "$LINENO" 5)'
> > Have you tried running this command?
> >
> >    autoreconf --verbose --force
> >
> > Maybe it is just that the autotools-related files are outdated.
> >
> >
> > --Kai
> >
> > _______________________________________________ Rpcemu mailing list
> > Rpcemu at riscos.info
> > http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu

Electronics  http://www.st-and.ac.uk/~www_pa/Scots_Guide/intro/electron.htm
Armstrong Audio  http://www.audiomisc.co.uk/Armstrong/armstrong.html
Audio Misc  http://www.audiomisc.co.uk/index.html

More information about the Rpcemu mailing list