[Rpcemu] Allegro not installed Mint 17

David Pitt pittdj at pittdj.co.uk
Wed Oct 1 11:14:37 PDT 2014


Sean Kelly, on 1 Oct, wrote:

[snip]
> 
> 4. Opened a terminal and issued the following commands - I know these
> shouldn't all be required, but it's what worked for me, eventually, as
> neither the deprecated nor the latest instructions on marutan.net worked.
> I'm thinking make clean won't be required for you, since it will all
> hopefully work first time.
> 
> cd rpcemu/src/ 
> aclocal 
> automake
> autoconf 
> make clean
> LIBS="-lm -lpthread" ./configure --enable-dynarec 
> make

Being unable to understand why I can build rpcemu on Mint 17 without the
slightest bother, whereas others are not so lucky I gave the above a try
with a newly unzipped source on a Mint 17 that already has a successfully
built rpcemu on it, that is the dependencies are already present and
correct. I did not get very far!

pittdj at pittdj-VirtualBox ~ $ cd rpcemu2/src
pittdj at pittdj-VirtualBox ~/rpcemu2/src $ aclocal
configure.ac:96: warning: macro 'AM_PATH_ALLEGRO' not found in library
pittdj at pittdj-VirtualBox ~/rpcemu2/src $ 


Take 3.

Ignoring the unnecessary steps.

pittdj at pittdj-VirtualBox ~/rpcemu3/src $ ./configure -enable--dynarec
pittdj at pittdj-VirtualBox ~/rpcemu3/src $ make

Build completes.

See http://marutan.net/rpcemuspoon/linuxcompile.html
-- 
David Pitt



More information about the Rpcemu mailing list