[Rpcemu] Allegro not installed Mint 17

tonynjac tonynjac at gmail.com
Mon Oct 6 07:29:18 PDT 2014


I don't know if this will help you,  but I recently tried to do the same 
and I recollect very similar errors even though I knew the allegro 
libraries were installed. The fix in the end was to install the 
build-essential package which for some reason doesn't seem to be 
included in the Mint 17 distro (well not in mine anyway).

/sudo apt-get update
sudo apt-get install build-essential/

In my efforts to get the compilation to work previously, I had been 
trying all sorts of commands (aclocal etc.) and I was concerned that I 
might have corrupted the download of rpcemu. So to be on the safe side, 
I threw away my old copy, downloaded a clean tar.gz from 
www.marutan.net, and unzipped it, so that I knew I had a copy as the 
distributors intended it to be.

Once I'd done that I just configured the package and compile/linked it 
using simply:

/./configure  --enable-dynarec//
And it worked without a problem.

Hope that helps



On 02/10/14 20:00, rpcemu-request at riscos.info wrote:
> Send Rpcemu mailing list submissions to
> 	rpcemu at riscos.info
> To subscribe or unsubscribe via the World Wide Web, visit
> 	http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu
> or, via email, send a message with subject or body 'help' to
> 	rpcemu-request at riscos.info
> You can reach the person managing the list at
> 	rpcemu-owner at riscos.info
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Rpcemu digest..."
> Today's Topics:
>     1. Re: Allegro not installed Mint 17 (Sean Kelly)
>     2. Re: Allegro not installed Mint 17 (Jim Lesurf)
> ----------------------------------------------------------------------
> Message: 1
> Date: Wed, 01 Oct 2014 20:45:55 +0100
> From: Sean Kelly <sean at caluse.net>
> To: rpcemu at riscos.info
> Subject: Re: [Rpcemu] Allegro not installed Mint 17
> Message-ID: <542C59F3.3060601 at caluse.net>
> Content-Type: text/plain; charset=windows-1252; format=flowed
>> Ignoring the unnecessary steps.
>> pittdj at pittdj-VirtualBox ~/rpcemu3/src $ ./configure -enable--dynarec
>> pittdj at pittdj-VirtualBox ~/rpcemu3/src $ make
>> Build completes.
> Not here it doesn't, that's what I first tried on my newly minted Mint.
> Here's what I got:
> ./configure: line 4634: syntax error near unexpected token `,'
> ./configure: line 4634: `   AM_PATH_ALLEGRO(, , as_fn_error $? "building
> RPCemu requires Allegro to be installed" "$LINENO" 5)'
> So I tried the lengthier, "largely deprecated",  instructions at
> www.riscos.info/index.php/RPCEmu_Linux_Guide and I got the same error as
> you at the same point:
> macro 'AM_PATH_ALLEGRO' not found in library
> I googled that, as a result I moved allegro.m4 and there was more
> progress - make started well, but then exited as belowr:
> /lib/i386-linux-gnu/libpthread.so.0: error adding symbols: DSO missing
> from command line
> This had happened exactly the same on Mint 16 so I went to the solution
> for that (thank you Kai), which you see below and which was successful.
> With the benefit of hindsight it seems that I've gone the long way round
> and that if I went back, copied allegro.m4 to the alternate location and
> then followed the simple two step process all would have been well, but
> had I not gone the long way round I wouldn't have had the error to
> google which fixed it for me.
> It is odd that even on a fresh install of the same OS there are
> differences which makes what works for one installation fail for
> another, maybe it is in some way related to hardware? - the DSO missing
> error, which is relatively common according to google, occurred when
> trying to compile RPCEmu on both my installs of Mint (on the same
> laptop) but not on yours - or most other folks', it seems.
> As far as I'm concerned, all's well that ends well and it's even better
> if I've learned a little in the process.
> Sean.
> On 01/10/14 19:14, David Pitt wrote:
>> Sean Kelly, on 1 Oct, wrote:
>> [snip]
>>> 4. Opened a terminal and issued the following commands - I know these
>>> shouldn't all be required, but it's what worked for me, eventually, as
>>> neither the deprecated nor the latest instructions on marutan.net worked.
>>> I'm thinking make clean won't be required for you, since it will all
>>> hopefully work first time.
>>> cd rpcemu/src/
>>> aclocal
>>> automake
>>> autoconf
>>> make clean
>>> LIBS="-lm -lpthread" ./configure --enable-dynarec
>>> make
>> Being unable to understand why I can build rpcemu on Mint 17 without the
>> slightest bother, whereas others are not so lucky I gave the above a try
>> with a newly unzipped source on a Mint 17 that already has a successfully
>> built rpcemu on it, that is the dependencies are already present and
>> correct. I did not get very far!
>> pittdj at pittdj-VirtualBox ~ $ cd rpcemu2/src
>> pittdj at pittdj-VirtualBox ~/rpcemu2/src $ aclocal
>> configure.ac:96: warning: macro 'AM_PATH_ALLEGRO' not found in library
>> pittdj at pittdj-VirtualBox ~/rpcemu2/src $
>> Take 3.
>> Ignoring the unnecessary steps.
>> pittdj at pittdj-VirtualBox ~/rpcemu3/src $ ./configure -enable--dynarec
>> pittdj at pittdj-VirtualBox ~/rpcemu3/src $ make
>> Build completes.
>> See http://marutan.net/rpcemuspoon/linuxcompile.html

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riscos.info/pipermail/rpcemu/attachments/20141006/98e82c39/attachment.html>

More information about the Rpcemu mailing list