[Rpcemu] Allegro not installed Ubuntu 14.04

Matthew Phillips spam2011m at yahoo.co.uk
Fri Oct 23 11:23:31 PDT 2015


In message <20151022233714.GB15853 at spod.org>
 on 23 Oct 2015 Peter Howkins  wrote:

> On Thu, Oct 22, 2015 at 10:23:26PM +0100, Matthew Phillips wrote:
> > This problem is awfully similar to that which people were getting a year ago
> > (the subject line referenced Mint 17).
> > 
> > I have installed liballegro4-dev, liballegro4.4 and liballegro4.4-plugin-alsa
> > 
> > I have gcc and build-essential.
> > 
> > When I do
> > 
> > cd rpcemu/src
> > aclocal
> 
> Why are you running aclocal?
> 
> http://www.marutan.net/rpcemu/linuxcompile.html
> 
> > ./configure
> 
> On a fresh copy, does ./configure on its own work?

No, it didn't.  I had followed the instructions on the page you refer to
first before I tried hunting for other suggestions.  Sorry I didn't make this
clear.

I was trying aclocal as part of a sequence of suggestions from the posting a
year ago from Sean Kelly:

----------------
To save you look up time, here's what I did from start to finish.

1. Downloaded and unpacked the RPCEmu source code 
http://www.marutan.net/rpcemu/cgi/download.php?sFName=0.8.11/rpcemu-0.8.11.tar.gz

2. Used the software manager in Mint to install liballegro4.2 and 
liballegro4.2-plugin-jack and liballegro4 liballegro4-dev.

3. Copied (I could have moved) allegro.m4 from /usr/local/share/aclocal/ 
to /usr/share/aclocal/

4. Opened a terminal and issued the following commands - I know these 
shouldn't all be required, but it's what worked for me, eventually, as 
neither the deprecated nor the latest instructions on marutan.net 
worked. I'm thinking make clean won't be required for you, since it will 
all hopefully work first time.

cd rpcemu/src/
aclocal
automake
autoconf
make clean
LIBS="-lm -lpthread" ./configure --enable-dynarec
make

Then it was just a matter of copying the ROMs etc.

----------------

My symptoms had been the same as those he reported a year ago, but I had no
allegro.m4 file anywhere in /usr

I have now had a go at copying allegro.m4 from my old laptop onto the Ubuntu
10.04 laptop and RPCEmu now compiles.  I am not sure which package is
supposed to supply the allegro.m4 file.  I was not able to install liballegro
4.2 as Ubuntu's oldest offering is 4.4.  I don't know whether that would
explain what happened.

-- 
Matthew Phillips
Durham



More information about the Rpcemu mailing list