[Rpcemu] RPCEmu and MacOSX

Gerald Holdsworth gerald at hollypops.co.uk
Wed Apr 20 11:28:57 PDT 2016


Hi Martin,

I’m still running 0.8.13, but on OSX 10.11.4. But, I’ve been using RPCEmu on the Mac since about  OS X 10.7.

Anyway, on my MacBook Air (2011 version), the F keys are used for various Mac functions (volume level, screen brightness, keyboard brightness, etc.), but can also be used in RISC OS. There is a setting hidden somewhere in the Mac OS X System Preferences that determine if the ‘fn’ key is required, or not, for these functions. I have it set so that I need to use the ‘fn’ key, and without the ‘fn’ key the normal F key gets passed to RISC OS (if any of that makes any sense!).

As for mouse gestures - does your touch wireless mouse do two finger clicks? On my laptop’s pad, a single finger click is like the left hand mouse button (translates to RISC OS Select), and a two finger click is like the right hand mouse button (translates, at least on mine, to RISC OS Menu). I haven’t tried a three finger click…yet. However, I believe there is a way to get the RISC OS Adjust click by pressing a key and a mouse click - this I haven’t found.

Hope this all helps.

Cheers,

Gerald.

From the MacBook Air of Gerald Holdsworth
www.geraldholdsworth.co.uk
www.reptonresourcepage.co.uk


> On 20 Apr 2016, at 17:41, Martin <rinfo at avisoft.f9.co.uk> wrote:
> 
> I have just installed RPCEmu 0.8.14 on a Mac running OSX 10.10.5, and
> have been suprised how much progress I managed to make. I installed the
> RO5.22 rom and matching HardDisc without any real problems, and it now
> boots nicely. The notes on the ROOL Wiki were invaluable. 
> 
> However, I did find some major usage problems probably caused by my lack
> of knowledge of OSX and Mac hardware.
> 
> The keyboard is a smallish wireless one, probably a predecessor of the
> current Magic Keyboard, as the key layout looks very similar. It has F1
> to F12 along the bottom of the top row of keys ... but I tried many
> combinations of Shift, FN, Alt & Ctrl keys and none seemed able to get me
> to a command line (or window). The Mac user never uses F keys!
> 
> The mouse is a touch wireless one, probably a predecessor of the current
> Magic Trackpad, as it looks very similar... but has no buttons at all. A
> sharp press anywhere on it seems to simulate a Select-click ok, but I
> have found no way to simulate either Menu-click or Adjust-click.
> 
> I was hoping to set it up for one specific use so a Mac user could run a
> small program I have written, so Select-click will enable that, and I
> could write a small program to do TaskManager_Shutdown instead of using
> Menu->Shutdown or Shift-Ctrl-F12. However, it would be nice if I could
> occasionally use a command line and Menu and Adjust (even if I needed an
> app to emulate them!).
> 
> Does anyone know whether TeamViewer will enable me to control RPCEmu on a
> Mac from my PC?
> 
> Thanks for any clues!
> 
> Martin
> 
> 
> _______________________________________________
> Rpcemu mailing list
> Rpcemu at riscos.info
> http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu




More information about the Rpcemu mailing list