[Rpcemu] RPCEmu Windows XP and Windows Vista support

Peter Howkins rpcemu.howkins at marutan.net
Thu Oct 3 14:37:28 PDT 2019


Due to needing to remain on a supported version of a library that we use to
build RPCEmu, future releases of RPCEmu will no longer support Windows XP or
Windows Vista. We will continue to support the Windows 7, 8 and 10 families.

What does this mean in detail?

1) All releases of RPCEmu so far released that do support Windows XP and
Vista will continue to run as they do currently. There is no magic code that
will disable old versions.

2) Previous versions of RPCEmu will continue to be available via the
previous
versions page, probably indefinitely.
 http://www.marutan.net/rpcemu/oldversions.html

3) Future Windows versions of RPCEmu will not be supported on Windows XP and
Vista. While it is theoretically possible they may still work, they will no
longer be tested, may partially work or fail in 'interesting' ways.

4) Bugs that are reported against previous versions on Windows XP and Vista,
that are not also present in the current, will not be investigated.

5) Bugs that are reported against previous versions on Windows XP and Vista,
that are present in the current version, will be investigated but the fixes
will come out in releases that are not compatible with Windows XP or Vista.

6) All good things come to an end, whilst we may be dropping support for
these older OSs, it is still 5 years more support than Microsoft gave the OS
itself.

Peter Howkins
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riscos.info/pipermail/rpcemu/attachments/20191003/1ff91f9b/attachment.html>


More information about the RPCEmu mailing list