[Rpcemu] RPCEmu 0.9.2

Steffen Huber steffen at huber-net.de
Sun Oct 27 08:17:26 PDT 2019


Hi David,

> dfeugey at ascinfo.fr wrote:
> 
> 
> Le 2019-10-26 16:11, Steffen Huber a écrit :
> 
> > 
> > Anyway, it does not work for me, neither with DHCP
> 
> Be sure to remove all options for gateway and DNS server as all is done 
> with DHCP.

I configured RISC OS networking perhaps a thousand times,
so I have that feeling that that part is not the problem.

> Here, it works well, apart from 'reduce CPU usage' completely broken on 
> RISC OS 5 and the lack of CallWin32 (it would be useful for so many 
> things).
> 
> RPCEmu is almost perfect now :)

I can't get networking to work. Neither on Windows 10, nor on Windows 7.
Neither via WLAN nor via LAN. Neither running as Admin or not. Neither
via DHCP nor via static IP. Neither with or without active Windows
firewall. Neither with my usual RISC OS 5 and RISC OS 4 installations
nor with a fresh reinstall of RISC OS 5.

DHCP gets 10.10.10.10 as IP. Which is certainly not an IP address
that my only DHCP server in the network would ever supply. Something
is very wrong here and I am running out of ideas what to try.

By "not working" I mean that ifconfig -a shows that (in the static
IP case) the IP address is correctly assigned, and route shows that
the route to the router is correctly set, and DNS is correctly
configured. But pinging the router/DNS server does not work. Pinging
any other machine on the network does not work. Name resolving
obviously does not work, either.

Any ideas?

Thanks
Steffen

-- 
Steffen Huber LambdaComm System – Welcome to Trollinger Country
steffen at huber-net.de
Private homepage http://www.huber-net.de/
RISC OS Blog http://riscosblog.huber-net.de/



More information about the RPCEmu mailing list