[Rpcemu] New 0.9.2 Mac binary release

Peter Moore petemoore at gmx.net
Mon Apr 27 11:42:21 PDT 2020


Hi guys!

I installed the new RPCEmu, and managed to dump an image of my RISC PC 600 hard drive using `dd` on linux.

I copied the raw hard disk image to the RPCEmuDataDir as hd4.hdf and have RISC OS 3.60 roms in place.

I followed the instructions on https://www.marutan.net/rpcemu/manual/#hdf but when i run the first command I get the following error:



RISC OS 24MB

Supervisor

*dir aufs::4.$

Disc drive not known (Error number &108AC)
*


My setup looks like this:


pmoore at Petes-iMac:~ $ cat ~/Library/Preferences/org.devrx.RPCEmu.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>NSNavLastRootDirectory</key>
	<string>~/Downloads/classicroms/RiscPC_A7000/RO_370/DiscImage</string>
	<key>NSNavPanelExpandedSizeForOpenMode</key>
	<string>{712, 459}</string>
	<key>RPCEmuDataDir</key>
	<string>/Users/pmoore/riscpc</string>
	<key>RPCHotKeysGrabbed</key>
	<false/>
</dict>
</plist>


and here you see the hard drive file:

pmoore at Petes-iMac:~ $ ls -l /Users/pmoore/riscpc/
total 841744
-rw-r--r--@ 1 pmoore  staff        256 21 Mar  2017 cmos.ram
-rw-r--r--  1 pmoore  staff  426360832 27 Apr 20:23 hd4.hdf
drwxr-xr-x@ 3 pmoore  staff         96 19 Mar  2017 hostfs
drwxr-xr-x@ 4 pmoore  staff        128 15 Feb  2016 poduleroms
drwxr-xr-x@ 5 pmoore  staff        160 15 Feb  2016 riscos-progs
drwxr-xr-x@ 4 pmoore  staff        128 19 Mar  2017 roms
-rw-r--r--@ 1 pmoore  staff        243 21 Mar  2017 rpc.cfg


Does the raw device file produced by dd need to be altered in any way for it to work?

On https://www.marutan.net/rpcemu/manual/#hdf, I couldn’t see exactly what format the hdf files need to be, so naively just tried using the raw file produced by dd, but suspect that might be the issue?

Thanks for anyone that can help, or redirect me to a better forum to ask the question.

Kind regards,
Pete

P.S. The dd command I used was `sudo dd of=hd4.hdf if=/dev/sdb` which generated the 420MB file which matches the size of the original hard drive. Running e.g. `strings hd4.hdf | grep Acorn` shows that the import seemed to work (there are lots of references to Acorn in the dump).


> On 24. Apr 2020, at 18:58, Timothy Coltman <lists at maemagel.com> wrote:
> 
> 
> 
>> On 24 Apr 2020, at 12:26, Tim Powys-Lybbe <tim at powys.org <mailto:tim at powys.org>> wrote:
>> 
>> 
>> I have tried to file some comments on GitHub but cannot find where to post them.  Guidance most welcome as I cannot get the program to run with a filesystem.
>> 
> 
> There is a new release of 0.9.2a that fixes this issue.  My packaging script was not including the "poduleroms" folder, which contains the modules for HostFS and its Filer module.  It was also including the "riscos-progs" folder which isn't required in a binary build.
> 
> You can download this from the same place as before:
> 
> https://github.com/Septercius/rpcemu-dev/releases <https://github.com/Septercius/rpcemu-dev/releases>
> 
> Tim
> 
> _______________________________________________
> RPCEmu mailing list
> RPCEmu at riscos.info
> http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riscos.info/pipermail/rpcemu/attachments/20200427/5b1c38bf/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screenshot 2020-04-27 at 20.33.10.png
Type: image/png
Size: 312996 bytes
Desc: not available
URL: <http://www.riscos.info/pipermail/rpcemu/attachments/20200427/5b1c38bf/attachment-0001.png>


More information about the RPCEmu mailing list