[Rpcemu] Cannot create rpcem0 interface

Bryan Hogan rpcemu at helpful-demon.co.uk
Wed Jun 10 23:24:52 PDT 2020


In message <abb92c3cf38dc1eaca6583983a0ee410456ecf39.camel at dpb.org.uk>
          Paul Bell <linux at dpb.org.uk> wrote:

> I've recreated my old SARPC RISC OS 4.02 setup from backups and got it
> booting and working but for the life of me I can not get networking to
> play ball. I just can't get the rpcem0 interface to appear!

Have you got the poduleroms and netroms directories in with the rpcemu 
executable?

> I'm on Arch Linux. RPCEmu 0.9.3. I've tried NAT and IP tunnelling. With
> IP tunnelling I can ping 172.31.0.1 from Linux but that's it, no rpcem0
> from RISC OS, just lo0.

> I've been through my !Boot with a fine tooth comb (as far as I can
> tell) and even tried copying files from your 3.71 bundle. Internet
> configuration via EtherRPCEm looks perfect. I'm at a loss, any
> suggestions please?

If you use the whole 3.71 bundle, does networking work?

If so you could try running both at once and go through the settings 
comparing them. (Ignoring that with RO4 you could turn on DHCP)

Bryan.

-- 
RISC OS User Group Of London  -  http://www.rougol.jellybaby.net/
RISC OS London Show           -  http://www.riscoslondonshow.co.uk/



More information about the RPCEmu mailing list