[Rpcemu] Cannot create rpcem0 interface

Paul Bell linux at dpb.org.uk
Fri Jun 12 04:29:22 PDT 2020


On Thu, 2020-06-11 at 16:29 +0100, Timothy Coltman wrote:
> > On 11 Jun 2020, at 14:44, Paul Bell <linux at dpb.org.uk> wrote:
> > 
> > On Thu, 2020-06-11 at 07:24 +0100, Bryan Hogan wrote:
> > > In message <
> > > abb92c3cf38dc1eaca6583983a0ee410456ecf39.camel at dpb.org.uk
> > >          Paul Bell <linux at dpb.org.uk> wrote:
> > > 
> > > > I've recreated my old SARPC RISC OS 4.02 setup from backups and
> > > > got
> > > > it
> > > > booting and working but for the life of me I can not get
> > > > networking
> > > > to
> > > > play ball. I just can't get the rpcem0 interface to appear!
> > > 
> > > Have you got the poduleroms and netroms directories in with the
> > > rpcemu 
> > > executable?
> > 
> > There is no netroms directory. RPCEmu comes with the dir
> > "riscos-progs" which includes the dirs "EtherRPCEm", "HostFS" and
> > "SyncClock".
> 
> You need the "netroms" folder for networking to work in the 0.9.x
> releases.  Inside "netroms" should be a file named
> "EtherRPCEm,ffa".  If you download the source archive from the main
> RPCEmu web site, you can find it there and copy it over.

I got rpcem0 to appear by manually entering the settings in a
TaskWindow and could resolve names but was unable to ping anything.

After adding the netroms folder (thanks all, missed that) rpcem0 was
available but I couldn't resolve. Adding BootResources:!Internet
(again?!) to run at startup resolves the resolving but I'm still
unable to ping anything.

I'll try tunnelling and report back.








More information about the RPCEmu mailing list